Communities

Writing
Writing
Codidact Meta
Codidact Meta
The Great Outdoors
The Great Outdoors
Photography & Video
Photography & Video
Scientific Speculation
Scientific Speculation
Cooking
Cooking
Electrical Engineering
Electrical Engineering
Judaism
Judaism
Languages & Linguistics
Languages & Linguistics
Software Development
Software Development
Mathematics
Mathematics
Christianity
Christianity
Code Golf
Code Golf
Music
Music
Physics
Physics
Linux Systems
Linux Systems
Power Users
Power Users
Tabletop RPGs
Tabletop RPGs
Community Proposals
Community Proposals
tag:snake search within a tag
answers:0 unanswered questions
user:xxxx search by author id
score:0.5 posts with 0.5+ score
"snake oil" exact phrase
votes:4 posts with 4+ votes
created:<1w created < 1 week ago
post_type:xxxx type of post
Search help
Notifications
Mark all as read See all your notifications »
Q&A

Post History

71%
+3 −0
#3: Post edited by user avatar zetyty‭ · 2023-08-06T20:59:29Z (10 months ago)
Add RVM to title
  • Warning about ruby version when moving to qpixel installation directory
  • Warning about ruby version when moving to qpixel installation directory with RVM
  • After ruby (version 3.1.2) install with rvm, when I move to the qpixel install directory (with `cd qpixel` command), the following warning is displayed in the terminal:
  • ```bash
  • Unknown ruby interpreter version (do not know how to handle): >=2.7,<4.
  • ```
  • But my local instance of QPixel seems to "work" without problem.
  • ## Questions
  • 1. Why I obtain this warning?
  • 2. What does it mean?
  • 3. Should I worry about for running my local instance of qpixel?
  • ## Setup
  • Ruby installed with: `rvm install 3.1.2`.
  • Output of `ruby -v` command on Debian 11 (on WSL2): `ruby 3.1.2p20 (2022-04-12 revision 4491bb740a) [x86_64-linux]`
  • I obtain the above warning with several OS: Debian 11 (WSL2) and 12, Ubuntu 22.04.2 TLS , Fedora 38 and Arch Linux.
  • After ruby (version 3.1.2) install with RVM, when I move to the qpixel install directory (with `cd qpixel` command), the following warning is displayed in the terminal:
  • ```bash
  • Unknown ruby interpreter version (do not know how to handle): >=2.7,<4.
  • ```
  • But my local instance of QPixel seems to "work" without problem.
  • ## Questions
  • 1. Why I obtain this warning?
  • 2. What does it mean?
  • 3. Should I worry about for running my local instance of qpixel?
  • ## Setup
  • Ruby installed with: `rvm install 3.1.2`.
  • Output of `ruby -v` command on Debian 11 (on WSL2): `ruby 3.1.2p20 (2022-04-12 revision 4491bb740a) [x86_64-linux]`
  • I obtain the above warning with several OS: Debian 11 (WSL2) and 12, Ubuntu 22.04.2 TLS , Fedora 38 and Arch Linux.
#2: Post edited by user avatar zetyty‭ · 2023-08-05T22:24:06Z (10 months ago)
  • Warning about ruby version when moving to qpixel directory
  • Warning about ruby version when moving to qpixel installation directory
#1: Initial revision by user avatar zetyty‭ · 2023-08-05T21:08:21Z (10 months ago)
Warning about ruby version when moving to qpixel directory
After ruby (version 3.1.2) install with rvm, when I move to the qpixel install directory (with `cd qpixel` command), the following warning is displayed in the terminal:

```bash
  Unknown ruby interpreter version (do not know how to handle): >=2.7,<4.
```

But my local instance of QPixel seems to "work" without problem.

## Questions

1. Why I obtain this warning?
2. What does it mean?
3. Should I worry about for running my local instance of qpixel?

## Setup

Ruby installed with: `rvm install 3.1.2`.

Output of `ruby -v` command on Debian 11 (on WSL2): `ruby 3.1.2p20 (2022-04-12 revision 4491bb740a) [x86_64-linux]`

I obtain the above warning with several OS: Debian 11 (WSL2) and 12, Ubuntu 22.04.2 TLS , Fedora 38 and Arch Linux.